Posts Tagged ‘act’

h1

WOOOOOOO GDB WINS!

January 6, 2009

So, I managed to isolate EVERY KNOWN BUG in RAVEN so far, and fixed them.  I feel good about that.  In addition, rendertargets are working in Direct3D.  I will add a depth target texture  for Direct3D rendertargets soon.  I also fixed the font not pixel perfect issue with Direct3D.  I had to shift the X,Y coordinates by -0.5, because apparently even untransformed vertices in Direct3D are not mapped directly to pixels.  Stuuuuuupid.  And I also added an alpha argument to the material constructor because having to set it after the fact is just plain hackish.  That also solved the fact that alpha wasn’t explicitly initialized, causing consistency problems.  Big time.  Another bug that was fixed.

All thanks to my l337 programming sk1lz and GDB.  Is there anything GDB can’t do?  Excellent debugger AND payload delivery system if you happen to be a hacker!

All I have to do at this point is get the Direct3D rendertarget working with a depth texture and stick in HLSL support.  It shouldn’t be too difficult (famous last words…lol) so stick around.  Then I can maybe add bitmap font support!  I’ll probably take an Irrlicht approach on that one, I really like their method.  I feel like this project is seriously trucking along!

And… I really hope I get my ACT results back soon enough to register for classes.  I feel somewhat worrisome.  If I can’t follow through, I’ll have to wait ’till next year.  And then I’ll have to wait and feel bad about myself… sigh.  Here’s hoping.

EDIT!

Seeing as how no one has commented yet, I feel fine just editing this post.  Here are some screenshots of the rendertargets working in Direct3D!  OpenGL is exactly the same in appearance, so really no need to post them.

If that isn’t just balling, I don’t know what is.  Next up:  HLSL support!

h1

big post + act finished + more 3D materials

January 3, 2009

HAY, IT’S TIME FOR A POST!

I haven’t posted in forever!  This is because of the following:

  • One of my best friends is in a rather nasty jam, and I am helping him.
  • I’ve been a bit more depressed than usual.
  • I’ve been studying for the ACT.
  • I’ve been working hardcore on an elusive problem with getting text to work in Direct3D.  It is a pixel data problem.  More on that later.
  • I’ve been spending time with *sigh* family on the holidays.
  • Reading Isaac Asimov’s Foundation and Empire.  VERY GOOD SCI-FI YOU MUST READ.
  • Sleep disorders are worse than ever.

But hey, you know, life’s still good!  I keep telling myself that anyway.  So really.

I just took the ACT.  It was pretty non-descript, mostly because I didn’t have enough caffiene in my system.  I hope I was still well off enough to do a good job.  My initial response to that was “meh…I’ll pass.”  I don’t really care, as long as it gets me in to college where the real learning begins.

In RAVEN, I’ve gotten a few more material/lighting things working, and I fixed the lighting inconsistencies, at least I believe so.  Per vertex alpha and material alpha both work, depending on whether the UseVertexColor flag is on.  Textures are great.  Here’s a problem for you though, text doesn’t work in Direct3D.  I’ve narrowed it down to the part where I copy the pixel data to the Direct3D textures.  The texture mapping works fine, the textures are valid, and I’ve done some printouts / diagnostics to check to see if the data is actually there when I copy it to the textures, and the answer is yes, it is there.  So everything works… but the copy.  It’s even D3DFMT_A8, just like the text data I copy to it.  One byte per pixel, that byte is an alpha value, am I mistaken?  Lock…memcpy…Release…Index…Render…FAIL!  Just blank quads.  T_T  I don’t know what the problem is, but I do need to slaughter right now!

And yes, I can’t sleep!  This is pissing me off!  I’m an insomniac, but I’ve barely slept at all this past week, and it can’t have helped my performance on the ACT today.  Ah well… life goes on.

Umm… that’s just about it.  Anyway.  I’m resuming normal posting now.